WS#32191: Unterstützte Versionen und Komponenten von CodX PostOffice

Laufende Weiterentwicklung

CodX PostOffice wird laufend weiterentwickelt um den Anforderungen und der Dynamik des Marktes gerecht zu werden. Neue Versionen werden in Form von Releases, Service-Packs und Hotfixes freigegeben.

Dieser WS-Artikel beschreibt die Unterstützung von Versionen von CodX PostOffice oder einzelnen Komponenten davon. Bitte verwenden Sie die Funktion 'Folgen' rechts oben. Damit erhalten Sie automatisch eine eMail, wenn dieser WS-Artikel aktualisiert wird.

Unterstützte Versionen von CodX PostOffice

CodX Software bietet Support und Dienstleistungen für alle unterstützten Versionen von CodX PostOffice. Für abgekündigte Versionen kann nur noch beschränkt Support oder andere Dienstleistungen angeboten werden. Die Supportleistungen für nicht mehr unterstützte Versionen wird in WS#37186 beschrieben.

Abgekündigte Versionen werden nicht mehr weiterentwickelt und keine Fehlerbehebung mehr geleistet. Ein Update von einer veralteten Version zur aktuellen Version von CodX PostOffice kann nicht gewährleistet werden. Es ist mit einer Neuinstallation des Systems zu rechnen.

Die Abkündigung von Versionen erfolgt immer für einen ganzen Release. Wie Versionen von CodX PostOffice gekennzeichnet sind, wird in WS#35945 beschrieben.

Die Versionen von CodX PostOffice werden wie folgt unterstützt:

Version Status
CodX PostOffice bis und mit V5 Wird nicht mehr unterstützt
CodX PostOffice V6 Unterstützt bis 31.12.2013
CodX PostOffice V7 Unterstützt bis 31.12.2014
CodX PostOffice V8 Unterstützt bis 31.12.2014
Ab CodX PostOffice V2013 Software wird während 3 Jahren unterstützt.
Beispiel: V2013.06 wird bis 2016 unterstützt.

CodX PostOffice Software-Module

Mit dem Einsatz von neuen Modulen und Funktionen in CodX PostOffice können alte Module abgekündigt werden. Die Module und Funktionen werden meist mit einem besseren, alternativen Lösungsansatz ersetzt. Die Abkündigung von Modulen und Funktionen, ohne alternativen Lösungsansatz erfolgt mindestens 3 Monate im Voraus.

Software-Modul Status
MS-Früh / MS-Spät (MS1) Wird bis und mit Version V2013.11 unterstützt. Ab V2014 durch Modul OS-AZD / MS-AZD ersetzt.
Upgrade von MS-Früh auf OS-AZD ist kostenpflichtig.
BV-Import Ab V2014.08 wird ausschliesslich der BV-Import V3 unterstützt. Die Beschreibung dazu finden Sie in der für die entsprechende Version aktuelle AdminDoc.

Microsoft Windows

CodX PostOffice setzt folgende Betriebssysteme voraus:

CodX PostOffice Microsoft Windows Server Microsoft Windows
CodX PostOffice ab V2013 Microsoft Windows Server 2008/R2 oder höher (32 / 64 Bit) Microsoft Windows 7 oder höher (32 / 64 Bit)

Microsoft SQL-Server

Der Microsoft SQL-Server ist eine zentrale Komponente von CodX PostOffice. CodX PostOffice benötigt als Voraussetzung für den einwandfreien Betrieb eine minimale Version und Konfiguration des Microsoft SQL-Servers. Abkündigungen von Versionen des Microsoft SQL-Servers erfolgen auf eine bestimmte Version von CodX PostOffice.

CodX PostOffice Microsoft SQL-Server
CodX PostOffice V5 Microsoft SQL-Server 2005, 2008, 2008/R2
CodX PostOffice V6 Microsoft SQL-Server 2005, 2008, 2008/R2
CodX PostOffice V7 Microsoft SQL-Server 2005, 2008, 2008/R2
CodX PostOffice V8.0 bis V8.5 Microsoft SQL-Server 2005, 2008, 2008/R2, 2012
CodX PostOffice ab V8.6 Microsoft SQL-Server 2008/R2, 2012
CodX PostOffice ab V2015.03 Microsoft SQL-Server 2008/R2, 2012, 2014, 2016

Microsoft Access

Microsoft Access wird für das Reporting und teilweise für Exports von Daten verwendet. CodX PostOffice unterstützt folgende Versionen von Microsoft Access.

CodX PostOffice Microsoft Access
CodX PostOffice bis und mit V8 Microsoft Access 2003 / 2007 (Vollversion / Runtime)
CodX PostOffice ab V2013 Microsoft Access 2007 (Vollversion / Runtime)

 

Explizit nicht unterstützt werden folgende Versionen von Microsoft Access:

  • Microsoft Access 2010 (Vollversion / Runtime)
  • Microsoft Access 2013 (Vollversion / Runtime)
  • Office 365

 

Hardware-Komponenten

Die Unterstützung von Hardware-Komponenten hängt insbesondere von der Lieferbarkeit durch die Hersteller ab. Normalerweise werden die Hardware-Komponenten noch eine Weile nach der Abkündigung durch den Hersteller von der Software CodX PostOffice unterstützt.

Die Abkündigung von Hardware-Komponenten erfolgt mindestens 3 Monate im Voraus über diese Webseite.

Hardware-Komponente Status Ersetzt durch
Labeldrucker PC4 Nicht mehr lieferbar. Wird von CodX PostOffice bis auf weiteres unterstützt. PF8

Labeldrucker E4

Nicht mehr lieferbar. Wird von CodX PostOffice bis auf weiteres unterstützt. PF4
Labeldrucker PF4 Nicht mehr lieferbar. Wird von CodX PostOffice bis auf weiteres unterstützt. Cx-PM43
Labeldrucker PF8 Nicht mehr lieferbar. Wird von CodX PostOffice bis auf weiteres unterstützt. Cx-OD5
Labeldrucker Cx-OD5 Wird von CodX PostOffice ab V2013 unterstützt. Unter Umständen auch für andere Versionen von V8. Bitte dazu die Release-Notes beachten.  
Labeldrucker Cx-PM43 Wird von CodX PostOffice ab V2013 unterstützt. Unter Umständen auch für andere Versionen von V8. Bitte dazu die Release-Notes beachten.  
Labeldrucker Cx-PD43 Wird von CodX PostOffice ab V2017 unterstützt. Anschluss über Windows-Treiber (USB)  
     
FP JetMail Nicht mehr lieferbar. Wird durch CodX PostOffice bis auf weiteres unterstützt. Siehe WS#37112 Übersicht unterstützter Frankier- und klein Sortiermaschinen von CodX PostOffice FP Centormail
FP UPOC-Modul (JetMail) Wird durch CodX PostOffice nicht mehr unterstützt. Siehe WS#37112 Übersicht unterstützter Frankier- und klein Sortiermaschinen von CodX PostOffice CxLetterScan
FP XMail (JetMail) Wird durch CodX PostOffice nicht mehr unterstützt. Siehe WS#37112 Übersicht unterstützter Frankier- und klein Sortiermaschinen von CodX PostOffice OCR-Station / CxLetterScan
     
OCR-Station V1 Nicht mehr lieferbar. Wird von CodX PostOffice bis auf weiteres unterstützt. OCR-Station V5
OCR-Station V2 Nicht mehr lieferbar. Wird von CodX PostOffice bis auf weiteres unterstützt. OCR-Station V5
OCR-Station V3 Nicht mehr lieferbar. Wird von CodX PostOffice bis auf weiteres unterstützt. OCR-Station V5
OCR-Station V4 Nicht mehr lieferbar. Wird von CodX PostOffice bis auf weiteres unterstützt. OCR-Station V5
OCR-Station V4.5 Nicht mehr lieferbar. Wird von CodX PostOffice bis auf weiteres unterstützt. OCR-Station V5
OCR-Station V5 Lieferbar ab 2018, bis auf weiteres unterstützt.  
FireBoard-400 Nicht mehr lieferbar. Wird von CodX PostOffice ab V2014 nicht mehr unterstützt. FireBoard-Blue
FireBoard-Blue Bis auf weiteres unterstützt  
     
ELFK I Nicht mehr lieferbar. Wird von CodX PostOffice bis auf weiteres unterstützt. ELFK 4
ELFK II Nicht mehr lieferbar. Wird von CodX PostOffice bis auf weiteres unterstützt. ELFK 4
ELFK III Nicht mehr lieferbar. Bis auf weiteres unterstützt. ELFK 4
ELFK 4 Lieferbar, bis auf weiteres unterstützt  
     
Waage Economy Nicht mehr lieferbar. Wird von CodX PostOffice bis auf weiteres unterstützt. Midrics (ausser OCR-Station V1 / V2)
Waage Midrics Bis auf weiteres unterstützt  
     
Opticon Scanner OPL 9723 Nicht mehr lieferbar. Wird von CodX PostOffice bis auf weiteres unterstützt.  MDEs
     
CxLetterScan Lieferbar, bis auf weiteres unterstützt.  
FlexiSort Wird nicht mehr unterstützt. CxLetterScan / OCR-Station

Sortiermaschinen über SSI

Standard Sorter Interface (SSI) von CodX PostOffice ist die standardisierte Schnittstelle zu Sortiermaschinen verschiedener Hersteller. Die nachfolgende Liste gibt Auskunft über die Unterstützung der Schnittstellen-Versionen. Die Abkündigung von SSI-Versionen erfolgt mindestens 12 Monate im Voraus über diese Webseite.

SSI Ab Version Bis Version
SSI V1.0 CodX PostOffice V2.0 CodX PostOffice V7.9
SSI V2.0 CodX PostOffice V3.4 CodX PostOffice V7.9
SSI V3.0 CodX PostOffice V4.0 Bis auf weiteres
SSI V3.1 CodX PostOffice V4.1 Bis auf weiteres
SSI V3.2 CodX PostOffice V4.3 Bis auf weiteres
SSI V3.3 CodX PostOffice V5.10 Bis auf weiteres
SSI V3.4 CodX PostOffice V5.10 Bis auf weiteres
SSI V3.5 CodX PostOffice V5.13 Bis auf weiteres
SSI V3.6 CodX PostOffice V6.7 Bis auf weiteres
SSI V3.7 CodX PostOffice V7.9 Bis auf weiteres
SSI V4.0 CodX PostOffice V8.1 Bis auf weiteres

 

Haben Sie Fragen? Anfrage einreichen

0 Kommentare

Bitte melden Sie sich an, um einen Kommentar zu hinterlassen.